Архив Автора: admin

tar -работа и манипуляция ленточными архивами

НАЗВАНИЕ

tar -работа и манипуляция ленточными архивами

СИНТАКИС

tar [bundled-flags <args>] [<file> | <pattern> …]

tar {-c} [options] [files | directories]

tar {-r | -u} -f archive-file [options] [files | directories]

tar {-t | -x} [options] [patterns]

ОПИСАНИЕ

tar создает и манипулирует потоковыми архивными файлами. Первая форма комманд содержит опцию «bundled». Такое использование делается в целях совместимости по историческим соображениям. За подробной информацией обращайтесь к разделу COMPATIBILITY. Остальные формы команд показывают предпочтительное использвание. Первая опция tar это индикатор состояния из следующего списка:

-c

Создает новый архив содержащий указанные файлы.

-r

Похож на -c, только новые строки добавляются к архиву. Учтите, что опция работает только с некомпрессироваными архивами содержащихся в регулярных файлах.

Требует опции -f.

-t

Выводит содержимое архива на стандартный вывод.

-u

Похож на -r, но новые строки добавляются только в том случае если они содержат дату изменения более новую, нежели находящаяся в архиве. Данная опция работает только в нескомпрессированых архивах хранящихся в регулярных файлах. Требует опции -f.

-x

Распаковывает на диск из архива. Если файл с тем же именем содержится более одного раза в архиве, каждая копия будет распакована, причем более поздняя копия заместит собой более ранние.

В -c, -r, или -u режимах, каждай указанный файл или директория добавляется к архиву в порядке указания в командной строке. По умолчанию, содержимое каждой директории так же архивируется.

В режиме распаковки или списка, вся командная строка читается и парсируется прежде,чем архив будет открыт. Имена путей или шаблонов в командной строке показывают,какие файлы в архиве должны быть обработаны. Стиль шаблонов схож со стилем шаблонов shell’а как описано в документе на tcsh(1).

ОПЦИИ

Если не указано иначе, опции применяются во всех режимах.

@archive

(только c и r режим) Указаный архив открывается и записи в нем будут применены к текущему архиву.

Простой пример,

tar -c -f — newfile @original.tar

записывает новый архив на стандартный вывод содержащий файл newfile и все записи из original.tar. Для контраста,

tar -c -f — newfile original.tar

создает новый архив только с двумя записями. Подобно,tar -czf — —format pax @- читает архив из стандартного ввода (чей формат определяется автоматически) и конвертирует его в компрессированый архив gzip pax формата на стандартный вывод. Таким образом tar может быть использован для конвертирования архивов из одного формата в другой.

-b blocksize

Указывает размер блока, в 512 байтовых записях, для ленточного накопителя. Как правило, данный аргумент необходим только тогда, когда происходит чтение или записть на ленточный накопитель, и обычно не нужен даже тогда когда размер блока по умолчанию 20 записей(10240 байт) что очень распространено.

-C directory

В режиме c и r, данная опция меняет директорию прежде чем добавит следующие файлы. В режиме x директория меняется после открытия архива, но прежде распаковки содержимого из архива.

—check-links (-W check-links)(

только c и r режимы). Выводит предупреждающее сообщение до тех пор, пока все ссылки на каждый файл не будут заархивированы.

—exclude pattern

(-W exclude=pattern)

Не обрабатывать файлы или директории, которые совпадают с указанным шаблоном. Учтите, что исключения имеют приоритет над шаблонами или именами файлов, указанных в командной строке.

—format format

(-W format=format)

(только режим c) Использует указанный формат для создания архива. Поддерживает все типы форматов включая «cpio», «pax», «shar», и «ustar». Другие форматы могут так же поддерживаться; смотрите libarchive-formats(5) для получения детальной информации о неподдерживаемых, в настоящее время, форматах.

-f file

Читать архив или записать архив в указанный файл. Именем файла может являтся — для стандартного вывода или ввода. Если опция не определена, по умолчанию будет использован ленточный накопитель. (Во FreeBSD, ленточный накопитель по умолчанию это /dev/sa0)

—fast-read

(-W fast-read)(только режимы x и t) Распаковывает или показывает только первое содержимое архива, которое совпадает с шаблоном или именем файла. Выходит сразу после того как совпал каждый указанный шаблон или имя файла. По умолчанию архив всегда

читается до конца, с этого момента могут попадаться множественные записи с одинаковыми именами и, по соглашению, поздние записи перезапишут более ранние. Эта опция предоставляет оптимизацию произовдительности.

-H

(только режим c и r) Следует по символическим ссылкам в командной строке;

цель на которую указывает ссылка будет зархивирована, а не сама ссылка.

-h

(только режим c и r) Синоним для -L

-I

Синоним для -T.

—include pattern

(-W include=pattern)

Обрабатывать только файлы или директории которые совпадают с указанным шаблоном. Учтите, что все исключения указанные в опции —exclude, имеют преймущество над включениями. Если включения не указаны, все строки обрабатываются по умолчанию. Опция —include особенно полезна, при фильтрации архивов.

Например, команда

tar -c -f new.tar —include=’*foo*’ @old.tgz

создает новый архив new.tar, содержащий только строки из old.tgz содержащий строку `foo’.

-j

(только режим c) Сжимает получившийся архив при помощи bzip2(1). В режиме извлечения или списка, эта опция игнорируется. Учтите следующее, в отличии от

других tar утилит, эта распознает компрессию bzip2 автоматически, когда читает архивы.

-k

(только режим x) Не перезаписывать существующие файлы. В частности, если файл появляется чаще чем один раз в архиве, поздние копии будут перезаписаны более ранними копиями.

-L

(только режим c и r) Следовать всем символическим ссылкам. Обычно, сами

ссылки архивируются. С этой опцией, вместо этого, будет зархивирована цель ссылки.

-l

Если указана опция окружения POSIXLY_CORRECT, это синоним для опции —check-links. Иначе, будет выведена ошибка. Пользователи, которые желают совместимости с GNU tar должны использовать вместо этого опцию —one-file-system.

-m

(только режим x) Не извлекать время модификации. По умолчанию, время модификации установлено во время, когда сохранялся архив.

-n

(только режим c,r и u) Не архивировать содержимое директорий рекурсивно.

—newer date

(-W newer=date) (только режим c,r и u) Только включая файлы и директории более новые чем указанная дата. Эта опция сравнивает записи ctimes.

—newer-mtime date

(-W newer-mtime=date)

(только режим c,r и u) Так же как —newer, за исключением того что опция

сравнивает записи mtime вместо записей ctime.

—newer-than file

(-W newer-than=file)

(только режим c,r и u) Только включает файлы и директории более новые, чем указанный файл. Сравниваются записи ctimes.

—newer-mtime-than file

(-W newer-mtime-than=file)

(только режим c,r и u) Так же как и —newer-than, за исключением того что сравниваются записи mtime вместо ctimes.

—nodump

(-W nodump)

(только режим c и r) Учитывает флаг файла nodump, пропуская этот файл.

—null

(-W null)

(использовать с -I, -T, или -X) Имена файлов или шаблоны разделяются null символами, а не символом новой строки. Это часто используется для чтения вывода имен файлов опцией -print0 для find.

-O

(только режимы x и t) В режиме распаковки (-x), файлы будут записаны на

стандартный вывод вместо записи на диск. В режиме списка (-t) список файлов будет

записан на stderr, вместо обычного стандартного вывода.

-o

(только режим x) Использовать пользователя и группу пользователей запускающих программу, вместо тех которые указаны в архиве. Это не существенно, до тех пор пока опция -p не определена, и программа не запущена пользователем root. В этом случае, режимы файлов из архива будут восстановлены, но ACL или информация о владельце восстановлена не будет.

—one-file-system

(-W one-file-system)

(только режим c,r и u) Не пересекать точки монтирования.

-P

Соблюдать имена пути. По умолчанию абсолютное имя пути (то которое начинается с символа /) имеет впереди слеш, который удаляется при создании архива или при распаковке. Так же tar откажется распаковывать записи в архиве, чьи имена пути содержат .. или чьи целевые директории будут изменены символической ссылкой. Эта опция отменяет данное поведение.

-p

(только режим x) Соблюдать файловые разрешения. Попытки восстановить полные разрешения, включая владельца, режимы файлов, флаги файлов и ACL, если они доступны для каждой записи извлекаемой из архива. По умолчанию, только что созданные файлы, принадлежат пользователю запустившему tar, режимы файла восстанавливаются для только что созданых регулярных файлов, и все другие типы записей получают разрешения по умолчанию. Если tar запущен пользователем root, по умолчанию будет восстановлен владелец, если опция -o не определена.

—strip-components count

(-W strip-components=count)

(только режимы x и t) Удаляет указанные номера из элементов пути. Имена пути с меньшим количеством элементов будут пропущены. Учтите, что имена пути редактируются после проверки включений/исключений шаблонов, но до проверок безопасности.

-T filename

В режиме x или t, tar будет читать список имен которые должны быть распакованы из filename. В режиме c, tar будет читать имена которые заарихиврованы из filename. Специальное имя «-C» в строке вызовет изменение директории указанной следующей строкой. Имена заканчиваются символом новой строки, если не указана опция —null. Опция —null так же выключит спецальную обработку строк содержащих «-C».

-U

(только режим x) Разлинковать файлы перед их созданием. Без этой опции, tar перезапишет существующие файлы без сохранения существующий жестких ссылок. С этой опцией существующие жесткие ссылки будут сломаны, так же как и любые символические ссылки могут изменить местонахождение распаковываемых файлов.

-v

Подробный вывод. В режимах создания и распаковки, tar покажет каждое имя файла который читается или записывается в архив. В режиме списка, tar произведет вывод соответствующий команде ls(1). Дополнительные опции -v предоставят дополнительный вывод.

-W longopt=value

Длиная опция (предваряемая —) напрямую поддерживается только в системах которые имеют  функцию getopt_long(3). Опция -W может использоваться для доступа к длиным операциям в системах, которые не поддерживают эту функцию.

-w

Спрашивает подтверждение для каждого действия.

-X filename

Читает список исключаемых шаблонов, из указанного файла. смотрите опцию —exclude для более детальной информации об обработке исключений.

-y

(только режим c) Сжимает получившийся архив с помощью bzip2(1). Режиме распаковки или списка, эта опция игнорируется. учтите следующее, в отличие от других реализаций tar, эта утилита распознает компрессию bzip2 автоматически, когда читает архив.

-z

(только режим c) Сжимает получившийся архив с помощью gzip2(1). Режиме распаковки или списка, эта опция игнорируется. учтите следующее, в отличие от других реализаций tar, эта утилита распознает компрессию gzip2 автоматически, когда читает архив.

ОКРУЖЕНИЕ

Следующие переменные изменят запуск tar:

LANG Используемая локаль. Смотрите environ(7) для более детальной информации.

POSIXLY_CORRECT

Если эта переменная окружения определена, опция -l интерпретируется в соответствии с ISO/IEC 9945-1:1996 («POSIX.1»).

TAPE

ленточный накопитель по умолчанию. опция -f отменяет эту переменную.

TZ

Временая зона используемая при отображении дат. Смотрите environ(7) для

дополнительной информации.

ФАЙЛЫ

/dev/sa0 ленточный накопитель по умолчанию. если не отменено окружение TAPE опцией

-f.

СТАТУС ВЫХОДА

утилита tar завершается с 0 при успешном выходе, и >0 если возникли ошибки.

ПРИМЕРЫ

Следующий пример создает новый архив, назваемый file.tar.gz, который содержит

2 файла source.c и source.h:

tar -czf file.tar.gz source.c source.h

Для просмотра подробной таблицы содержимого этого архива:

tar -tvf file.tar.gz

Для извлечения всех записей из архива на ленточный накопитель установленный по умолчанию:

tar -x

Для перемещения файловых иерархий, вызовите tar так

tar -cf — -C srcdir . | tar -xpf — -C destdir

либо более традиционно

cd srcdir ; tar -cf — . | (cd destdir ; tar -xpf -)

В режиме создания, список файлов и директорий которые должны быть так же заархивированы, могут включать команды смены директорий в форме -Cfoo/baz и включаемые архивы в форме @archive-file. например, командная строка

tar -c -f new.tar foo1 [color=brown]@old.tgz[/color] -C/tmp foo2

создаст новый архив new.tar. tar прочитает файл foo1 из текущей директории и добавит его к выходному архиву. затем он прочтет каждую запись из файла old.tgz и добавит эти записи в выходной архив. Наконец, он сменит директорию /tmp и добавит foo2 к выходному архиву.

опции —newer и —newer-mtime поддерживают разнообразные спецификации времени и даты, включая «12 Mar 2005 7:14:29pm», «2005-03-12 19:14», «5 minutes ago», and «19:14 PST May 1».

СОВМЕСТИМОСТЬ

Формат связанных аргументов поддерживается для совместимости с историческими реализациями. Он содержит инициируемое слово (без символа — в начале) в котором каждый символ указывает на опцию. Аргументы следуют как раздельные слова. Порядок документов должен совпадать с порядком следования символов в связаном слове. Например,

tar tbf 32 file.tar

определяет флаги t, b, and f. Флаги b и f — оба требуют аргументов, поэтому должны быть 2 дополнительных аргумента в командной строке. Аргумент 32[color] аргумент

флага [color=brown]b, и file.tar аргумент флага f. Опции режима c, r, t, u, и x, и опции

b, f, l, m, o, v, и w выполняют с SUSv2.

Для максимальной переносимости, скрипты которые вызывают tar должны использовать связные аргументы описаные выше, должны ограничить себя режимами c, t, и x и опциями b, f, m, v, и w.

В системах, которые поддерживают getopt_long(), дополнительные длиные опции

могут увеличить совместимость с другими реализациями tar.

БЕЗОПАСНОСТЬ

Определенные проблемы безопасности рапространены во многих архиваторах, включая tar. Частично, тщательно обработанные архивы могут попросить извлеч файлы в место отличное от целевой директории. Потенциально это может быть использовано для того что бы невольно заставить пользователя перезаписать файлы, которые он не хотел перезаписывать. Если архив извлекается суперпользователем, любой файл в системе может быть потенциально перезаписан. Это может случиться по трем причинам.

Хотя tar и имеет механизмы для защиты друг друга, здравомыслящие пользователи

должны знать о реализациях:

1.Записи в архивах имеют абсолютные имена пути. По умолчанию, tar удаляет

начальные / символы из имен файлов прежде чем восстановит их, для предотвращения

этой проблемы.

2. Записи в архивах могут иметь имена пути которые содержат .. . По умолчанию, tar

не распакует файлы содержащие такие .. компоненты в именах пути.

3. Записи в архивах могут могут использовать символические ссылки для восстановления файлов в других директориях. Архив может восстановить символическую ссылку в другую директорию, затем использовать эту ссылку для восстановления файла в эту директорию. Для защиты от этого, tar проверяет каждый распакованый путь на символические ссылки. Если последний элемент пути является символической ссылкой, он будет удален и замещен записью в архиве. Если указана опция -U, любая промежуточная символическая ссылка будет так же удалена. Если опции -U или -P не указаны, tar откажется распаковывать строку. Для защиты себя, вы должны опасаться любых архивов, которые поступают из недостоверных источников. Вы должны проверять содержимое архива

tar -tf filename

прежде, чем начнете распаковку. Вы должны использовать опцию -k для того что бы

быть увереным что tar не перезапишет существующие файлы или опцию -U для удаления всех существующих файлов. Обычно вы не должны распаковывать архивы пока используете привелегии суперпользователя. Учтите, что опция -P отключает проверки безопасности tar’а и позволяет распаковать архивы с сохранением абсолютных имен пути, .. компонентами, или символическими ссылками на другие директории.

Смотрите так же

bzip2(1), cpio(1), gzip(1), mt(1), pax(1), shar(1), libarchive(3),

libarchive-formats(5), tar(5)

Стандарты

На данный момент нет стандарта POSIX для команды tar он появился в ISO/IEC 9945-1:1996 («POSIX.1») но был выброшен из IEEE Std 1003.1-2001 («POSIX.1»). Опции используемые данной реализацией были разработаны с учетом множества реализаций tar, так же как и с учетом старой спецификации POSIX и текущей спецификации  POSIX.

Ustar и pax файловые форматы обмена были определены IEEE Std

1003.1-2001 («POSIX.1») для команды pax.

История

команда tar появилась в Седьмой Редакции Unix. Были некоторые другие реализации, многие из них расширяли формат файла. Реализация John Gilmore’а pdtar находящаяся в общем владении, в некотором роде повлияла и сформировала основы GNU tar. GNU tar был включен как часть стандартной системы tar в FreeBSD начиная с FreeBSD 1.0.Это полная новая реализация основанная на библиотеке libarchive(3).

Ошибки

POSIX и GNU жестко расходятся в том, какое значение несет опция -l. Из-за потенциальной угрозы, когда кто-то ожидает одного поведения а получает другое, опция -l преднамеренно отсутствует в данной реализации.

Опция -C dir может отличатся от исторической реализации.

Весь вывод архива написан в блоках корректного размера, даже если вывод был сжат. Дополняет ли последний блок полный размер блока, зависит от формата выходного устройства. Для tar и cpio, последний выходной блок добавляется к полному размеру блока, если вывод был произведен на стандартный вывод или в символьное или блочное устройство, такое как ленточный накопитель. Если вывод был записан в файл, последний блок не добавляется. Многие утилиты сжатия, включая gzip(1) и bzip2(1) жалуются об отсутствии нулевого добавления в момент декомпрессии архива созданного tar’ом,

но они распакуют его правильно. Сжатие и декомпрессия реализовано внутри, поэтому много существенных отличий между сжатым выводом созданным

tar -czf — file

и созданым

tar -cf — file | gzip

По умолчанию нужно читать и записывать архивы на стандартный ввод/вывод, но традиция (и POSIX) утверждают другое.

Режимы r и u требуют что бы архив был несжатым и находился в файле на диске. Другие архивы могут быть модифицированы используя режим c, с расширением @archive-file.

Для архивации файла называемого @foo или -foo вы должны указать их как ./@foo или ./-foo, соответственно.

В режиме создания первые ./ всегда удаляются. Первый / удаляется, пока не будет

указана опция -P.

Нужна более лучшая поддержка для выбора файлов при создании и распаковки.

Нет поддержки многотомных архивов или архивирования редких файлов.

Конвертирование между различными архивными форматами (таких как tar или cpio) используя опцию  @- может вызвать потерю информации (последствие несовместимых путей благодаря которым различные форматы архивов хранят информацию о жестких ссылках.

Есть альтернативные длиные опции, для многих коротких опций которые преднамеренно не задокументированы.

bspatch — применить патч, полученный с помощью утилиты bsdiff(1)

НАЗВАНИЕ

bspatch — применить патч, сгенерированный утилитой bsdiff(1)

СИНТАКСИС

bspatch старый_файл новый_файл файл_патча

ОПИСАНИЕ

Утилита bspatch генерирует новый_файл, используя для этого старый_файл и

файл_патча, где файл_патча — это бинарный патч, полученный с помощью bsdiff(1).

Утилита bspatch использует память, равную сумме размеров файлов

старый_файл и новый_файл, но может работать с очень маленьким рабочим

набором памяти без существенной потери производительности.

СМОТРИ ТАКЖЕ

bsdiff(1)

Открытие большого количества репозиториев для APT

В предыдущих версиях Ubuntu multiverse- и universe-репозитории по умолчанию были недоступны. Сейчас они по умолчанию открыты для Ubuntu, и, таким образом, обновление программ и их поиск могут осуществляться со значительно большим количеством параметров. 

Единственным недостатком является тот факт, что поддержка, лицензирование и файлы с исправлениями недоступны для universe-и multiverse-репозиториев. 

Чтобы отключить universe- или muliverse-репозитории, откройте в текстовом редакторе файл /etc/apt/sources.list и закомментируйте строки, имеющие включенные multiverse- или 

universe-компоненты. При желании, чтобы отметить закомментированные элементы, добавьте к 

строкам комментарии. В следующих примерах подпись отмечена знаком #сn:

#cn deb http://us.archive.ubuntu.com/ubuntu/ feisty universe

#cn deb-src http://us.archive.ubuntu.com/ubuntu/ feisty universe 

#cn deb http://us.archive.ubuntu.com/ubuntu/ feisty multiverse

#cn deb-src http://us.archive.ubuntu.com/ubuntu/ feisty multiverse

Аналогично, если вы захотите добавить дополнительные репозитории, которые могут быть предложены частными лицами или компаниями, добавьте соответствующую строку в файл /etc/apt/sources.list. Для редактирования этого файла вы должны обладать правами суперпользователя:

$sudo vi /etc/apt/sources.list

Добавьте строку, начав с deb (если речь идет об уже готовых пакетах) или deb-src (если речь идет об исходном коде), затем URL-адрес репозитория вместе с дистрибутивом (как feisty в предыдущем примере) и описания компонентов (приеры universe). Обычно компоненты описываются как contrib-предоставленные (то есть не имеющие отношения к проекту Ubuntu) и free (свободные) или non-free (несвободные). Обычно подобная информация содержится на сайте, предоставляющем репозитории.

rmdir — удаление каталогов

Синтаксис

rmdir{-pv] каталог

Описание

Утилита rmdir удаляет каталоги, заданные аргументами каталог, в том случае,если они пусты.

Аргументы обрабатываются в указанном порядке, поэтому для удаления и родительского

каталога, и его подкаталога вначале должен быть указан подкаталог, чтобы родительский

каталог был уже пуст на момент, когда rmdir попытается его удалить.

Имеются следующие опции:

-p

Каждый каталог рассматривается как путь, все компоненты которого будут удалены,

если они пусты, начиная с последнего компонента. (О рекурсивном удалении без проверки на

то, пуст каталог или нет,смотрите rm(1).)

-v

Выводить подробную информацию, показывая каталоги по мере их удаления.

Код завершения

Команда rmdir завершается с одним из следующих статусов:

0 Каждый каталог, указанный операндом каталог, оказался пустым и был успешно удалён.

>0 Произошла ошибка.

Смотри также

rm(1)

Настройка Cisco ASA 5510 c демилиторизованной зоной

 

Стояла задача настроить

Cisco ASA 5510

для разрешения работы серверов и пользователей локальной сети предприятия.

Причем,

сервера имеют белые

(Интернетовские  типа 62.ххх) адреса и работают через

static

. Данные же пользователей пропускаем через

NAT

.

Сервера имеют две сетевые карты: одна — в локальной сети, другая — Интернет, и управляются через локальную сеть. Поэтому доступ из локальной сети в DMZ  не настроен, ибо не нужен.

Образец конфигурации дан ниже.

 !

ASA Version 8.2(1)

!

!

Имя Cisco

hostname asa

!Домен . Нужно для SSH

domain-name strui.ru

!Пароль для enable.

enable password 4аееoLOxxxxxxjMx encrypted

passwd k0a6sN9ExxxxxxxxzV encrypted

names

! Описание интерфейса, смотрящего в Internet

.

interface Ethernet0/0

description Internet

nameif outside

security-level 0

ip address 213.xxx.xxx.194 255.255.255.240

! Описание интерфейса, смотрящего в локальную сеть

.

interface Ethernet0/1

description Local

nameif inside

security-level 100

ip address 10.10.10.20 255.255.255.0

!

! Описание интерфейса, смотрящего в сеть серверов (DMZ)

interface Ethernet0/2

description DMZ

nameif dmz

security-level 50

ip address 62.xxx.xxx.177 255.255.255.240

!Этот интерфейс выключен

interface Ethernet0/3

shutdown

no nameif

no security-level

no ip address

!

Этот интерфейс выключен( не привязан к локальной сети). Использовался при

!первоначальной настройке Cisco  

interface Management0/0

nameif management

security-level 100

ip address 192.168.1.1 255.255.255.0

management-only

!

ftp mode passive

! Выставляем зону и время. Необходимо для логов.

clock timezone MSK/MDD 3

clock summer-time MSK/MDD recurring last Sun Mar 2:00 last Sun Oct 3:00

dns server-group DefaultDNS

! Лист доступа в демилиторизованную зону  к серверам. Входящий трафик.

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.180 eq www

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.180 eq ftp

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.180 eq ftp-data

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.181 eq www

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.181 eq ftp

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.181 eq ftp-data

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.178 eq domain

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.179 eq smtp

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.179 eq pop3

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.179 eq imap4

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.184 eq 8081

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.184 eq www

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.185 eq www

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.186 eq ftp

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.186 eq ftp-data

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.186 eq www

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.189 eq www

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.179 eq domain

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.179 eq https

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.182 eq smtp

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.182 eq pop3

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.182 eq imap4

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.184 eq rtsp

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.187 eq www

access-list acl_in_dmz extended permit tcp any host 62.xxx.xxx.188 eq www

! Лист доступа для серверов из демилиторизованной зоны. Исходящий трафик.

access-list acl_out_dmz extended permit tcp any any

access-list acl_out_dmz extended permit udp any any

access-list acl_out_dmz extended permit icmp any any

access-list acl_out_dmz extended deny tcp host 62.xxx.19.76 host 213.xxx.36.194 eq 135

access-list acl_out_dmz extended deny tcp host 87.xxx.95.11 host 213.xxx.36.194 eq ftp

!Лист доступа для пользователей локальной сети.

! Разрешено все для исходящего трафика.

access-list acl_out_inside extended permit tcp 10.10.10.0 255.255.255.0 any

access-list acl_out_inside extended permit tcp 10.10.20.0 255.255.255.0 any

access-list acl_out_inside extended permit tcp 10.10.40.0 255.255.255.0 any

access-list acl_out_inside extended permit tcp 10.10.50.0 255.255.255.0 any

access-list acl_out_inside extended permit tcp 10.10.110.0 255.255.255.0 any

access-list acl_out_inside extended permit icmp 10.10.10.0 255.255.255.0 any

access-list acl_out_inside extended permit icmp 10.10.110.0 255.255.255.0 any

access-list acl_out_inside extended permit icmp 10.10.20.0 255.255.255.0 any

access-list acl_out_inside extended permit icmp 10.10.50.0 255.255.255.0 any

access-list acl_out_inside extended permit udp 10.10.10.0 255.255.255.0 any

access-list acl_out_inside extended permit udp 10.10.20.0 255.255.255.0 any

access-list acl_out_inside extended permit udp 10.10.110.0 255.255.255.0 any

access-list acl_out_inside extended permit udp 10.10.50.0 255.255.255.0 any

access-list acl_out_inside extended permit udp 10.10.40.0 255.255.255.0 any

pager lines 24

! Настройка логирования

logging enable

logging timestamp

logging trap notifications

logging asdm informational

logging host inside 10.10.10.4

mtu outside 1500

mtu inside 1500

mtu dmz 1500

mtu management 1500

no failover

icmp unreachable rate-limit 1 burst-size 1

no asdm history enable

arp timeout 14400

! Настройка global

global (outside) 1 interface

! Настройка NAT для локальной сети 

nat (inside) 1 0.0.0.0 0.0.0.0

! Настройка static для серверов

nat (dmz) 0 0.0.0.0 0.0.0.0

static (dmz,outside) 62.xxx.xxx.180 62.xxx.xxx.180 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.181 62.xxx.xxx.181 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.178 62.xxx.xxx.178 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.179 62.xxx.xxx.179 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.184 62.xxx.xxx.184 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.185 62.xxx.xxx.185 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.186 62.xxx.xxx.186 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.189 62.xxx.xxx.189 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.187 62.xxx.xxx.187 netmask 255.255.255.255

static (dmz,outside) 62.xxx.xxx.188 62.xxx.xxx.188 netmask 255.255.255.255

! Привязываем access-list через  access-group  к интерфейсам.

access-group acl_in_dmz in interface outside

access-group acl_out_inside in interface inside

access-group acl_out_dmz in interface dmz

! Прописываем маршрутизацию для интерфейсов.

route outside 0.0.0.0 0.0.0.0 213.xxx.xxx.193 1

route inside 10.10.20.0 255.255.255.0 10.10.10.10 1

route inside 10.10.40.0 255.255.255.0 10.10.10.10 1

route inside 10.10.50.0 255.255.255.0 10.10.10.10 1

route inside 10.10.110.0 255.255.255.0 10.10.10.10 1

timeout xlate 3:00:00

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

dynamic-access-policy-record DfltAccessPolicy

! Разрешаем работу через WEB морду из локальной сети.

http server enable

http 10.10.10.0 255.255.255.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec security-association lifetime seconds 28800

crypto ipsec security-association lifetime kilobytes 4608000

! Разрешаем работу  telnet  и ssh по локальной сети.

telnet 10.10.10.0 255.255.255.0 inside

telnet timeout 5

ssh 10.10.10.0 255.255.255.0 inside

ssh 10.10.10.71 255.255.255.255 inside

ssh timeout 30

console timeout 0

dhcpd address 192.168.1.2-192.168.1.254 management

!

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

! Сервер времени и пользователь для WEB морды.

ntp server 10.10.10.3 source inside

webvpn

username admin password trAp5eVxxxxxxnv encrypted privilege 15

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

message-length maximum 512

policy-map global_policy

class inspection_default

inspect dns preset_dns_map

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp

!

service-policy global_policy global

prompt hostname context

Cryptochecksum:58da28923df5a5f8d5192125f9b1796f

: end 

Настройка Web-сервера apache под Ubuntu

1)Установливаем классическую связку — Apache + PHP + MySQL:

#apt-get install apache2 mysql-server-5.0 php5 php5-gd php5-mysql acl

2)Создаем каталог для сайта и распакуем туда предварительно закаченную CMS joomla:

# mkdir /var/www/joomla

3)Сменим владельца каталога:

chown -R www-data.www-data /var/www/joomla/

4)и права на каталог:

chmod -R 755 /var/www/joomla/

5)Создадим виртуальный хост для CMS joomla:

vim /etc/apache2/sites-available/joomla.conf

 

Читать далее

Допишем в созданный файл:

<VirtualHost *:80>

ServerAdmin

admin(собака)joomla.ru

DocumentRoot /var/www/joomla

<Directory /var/www/joomla>

AllowOverride all

Order  allow,deny

Allow from all

</Directory>

ServerName joomla

</VirtualHost>

6)В /etc/apache2/apache2.conf допишем:

ServerName localhost

7)Включим сайт:

a2ensite joomla

8)После выполнения этих команд обновим конфигурацию  работающего apache:

# /etc/init.d/apache2 reload

9)Создадим БД для сайта:

#mysql -p

CREATE DATABASE joomla;

GRANT ALL PRIVILEGES ON joomla.* TO joomla_admin@localhost IDENTIFIED BY ‘password’;

Дополнительно:

1)

/etc/apache2/apache2.conf

главный конфигурационный файл

2)Каталоги в /etc/apache2/:

mods-available — установленные в систему модули, хранит сами модули и их конфигурационные файлы

mods-enabled — подключенные модули, хранит ссылки на файлы в mods-available

sites-available — доступные сайты, хранит файлы описывающие виртуальные хосты

sites-enabled — подключенные сайты, хранит ссылки на файлы в sites-available

3)Четыре команды, которыми будем создавать и удалять ссылки в диалоговом режиме:

a2enmod — подключает модуль

a2dismod — отключает модуль

a2ensite — подключает сайт

a2dissite — отключает сайт

4) Если возникли проблемы с кодировкой веб-страниц, необходимо в конфиге apache2 (/etc/apache2/apache2.conf), задать параметр:

AddDefaultCharset Off

which — найти программный файл в пользовательском пути поиска

Синтаксис

which [-as] команда …

Описание

Для каждой команды из списка аргументов, утилита which ищет путь к испол

няемому файлу, который был бы запущен в случае вызова данной команды.

Имеются следующие опции:

-a

Выводить все найденные экземпляры исполняемых файлов для каждой

команды, а не только первый из них.

-s

Ничего не выводить, а только установить код возврата 0, если все

исполняемые файлы были найдены, либо 1, если хотя бы один не был

найден.

Некоторые командные оболочки имеют встроенную команду which с похожей

либо идентичной функциональностью. Обратитесь к странице справочника

builtin(1).

Смотри также

builtin(1), csh(1), find, locate(1), whereis(1)

fsync — синхронизировать состояние файла в памяти с его состоянием на диске

FSYNC(1)

НАЗВАНИЕ

fsync — синхронизировать состояние файла в памяти с его состоянием на диске.

СИНТАКСИС

fsync файл …

ОПИСАНИЕ

Утилита fsync заставляет все изменённые данные и мета-данные всех указанных в командной строке файлов быть записанными в устройство постоянного хранения. Утилита fsync использует системный вызов fsync(2).

СТАТУС ЗАВЕРШЕНИЯ

При возникновении ошибки, утилита fsync переходит к следующему файлу и возвращает >0.

В противном случае утилита возвращает 0.

СМОТРИ ТАКЖЕ

fsync(2), sync(2), syncer(4), halt(8), reboot(8)

ИСТОРИЯ

Команда fsync впервые появилась во FreeBSD 4.3.

Инсталляция Vmware ESXi

Настало время собирать камни…

Начальник как-то сказал, что у нас развелось  многова-то серверов и пришло время их количество уменьшить. Решили начать с Unix. Три сервера с помощью vmware размещаем на одном сервере и смотрим как это работает.

Причем, используем бесплатную версию VmWare ESXi. Если все будет нормально работать, то покупаем vmware  под сервера Windows.

Так что, намечается немаленькая серия статей о программном обеспечении VmWare.

Ну а мы начнем  с инсталляции.

Сначала регистрируемся на сайте vmWare, и получаем возможность пользоваться бесплатно тремя программными продуктами:

VMware ESXi 4.1

VMware vSphere Client

VMware Go

На Ваш почтовый адрес, указанный при регистрации, придет запрос на активацию.

Вам необходимо будет нажать на строчку:

Activate your VMware vSphere Hypervisor License and access your download

и получить номер лицензии и доступ к бинарникам для закачки.

Лицензия wmware

Естественно, необходимо проверить совместимость оборудования и записать закаченное на CD-диск.

Считаем , что все прошло удачно, вставляем диск  и  c него загружаемся.

Инсталляция Vmware ESXi

Выбираем ESXi Installer

Инсталляция Vmware ESXi

Инсталляция Vmware ESXi

Инсталляция Vmware ESXi

Внимательно читаем лицензию.

Инсталляция Vmware ESXi

Выбираем диск, с которого будет загружаться vmware.  При  этом не забываем, что все данные на нем будут уничтожены.

Install Vmware ESXi

Подтверждаем установку.

Install Vmware ESXi

Install Vmware ESXi

Перезагружаемся и видим предложение скачать утилиты управления  с http://localhost.

Если у Вас в сети имеется настроенный DHCP-сервер, то получите следующую картинку на консоли сервера.

Install Vmware ESXi

В следующей статье рассмотрим пост-инсталляционную настройку vmware  и VMware vSphere Client.

who — показать кто подключен к системе

WHO(1)

НАЗВАНИЕ

who — показать кто подключен к системе

СИНТАКСИС

who [-HmqsTu] [am I] [файл] ОПИСАНИЕ Утилита who выводит информацию о пользователях, подключенных к системе. По умолчанию выводятся следующие поля: учётное имя пользователя, имя пользовательского терминала, дата и время подключения, а также имя удалённого хоста, если подключение нелокальное.

Имеются следующие опции:

-H

Показать заголовки колонок.

-m

Вывести информацию только о терминале, подключенному к стандартному вводу.

-q

«Быстрый режим»: Вывести по колонкам имена и общее число подключенных пользователей. Все остальные опции командной строки при этом игнорируются.

-s

Показать только имя, терминал подключения и время. Эти данные выводятся по умолчанию.

-T

Показать, принимает ли каждый пользователь сообщения.

Выводится один из следующих символов:

+

Пользователь принимает сообщения.

Пользователь не принимает сообщения.

?

Произошла ошибка.

-u

Показать время бездействия для каждого пользователя в часах и минутах в виде hh:mm, `.’ если пользователь бездействовал менее минуты, и «old» если пользователь бездействовал более 24 часов.

am I

Эквивалентно -m.

По умолчанию, утилита who получает информацию из файла /var/run/utmp. Может быть указан альтернативный файл, обычно /var/log/wtmp (или /var/log/wtmp.[0-6] в зависимости от настроек системы; так как файл wtmp может стать достаточно большим, ежедневные версии могут сохраняться или не сохраняться после упаковки их с помощью ac(8)). Файл wtmp содержит записи о каждом входе и выходе из системы, сбоях, выключениях и сменах даты, начиная с последнего момента его создания или усечения. Если в качестве информационного файла выбран /var/log/wtmp, то имя пользователя может оказаться пустым, или одним из специальных символов ‘|’, ‘}’ и ‘~’. При отключении от системы записывается строка без имени пользователя. Чтобы узнать больше о специальных символах, смотрите utmp(5).

ОКРУЖЕНИЕ

Переменные окружения COLUMNS, LANG, LC_ALL и LC_TIME влияют на выполнение who так, как описано в environ(7).

ФАЙЛЫ

/var/run/utmp /var/log/wtmp /var/log/wtmp.[0-6]

СТАТУС ЗАВЕРШЕНИЯ

Утилита who возвращает 0 в случае успешного завершения и >0 в случае возникновения ошибки.

СМОТРИ ТАКЖЕ

last(1), users(1), w(1), utmp(5) СТАНДАРТЫ Утилита who соответствует стандарту IEEE Std 1003.1-2001 («POSIX.1»).