Работаем с Cisco 2800 не зная пароля.

Послал меня начальник недавно смотреть настройку маршрутизатора Cisco 2800.

Приезжаем. Логинимся на нее по Telnet — запрашивает пользователя и пароль.

Логинимся через консоль — тоже самое. А вот имя пользователя и пароль никто и не знает.

Эта статья о том как решить подобную задачу.

Статей на эту тему написано много — но в большинстве своем они одинаковые и неполные.

Я же пишу эту заметку для себя, чтобы,если придется снова вводить пользователя или менять пароль,не забыть.

Что мне надо было получить?

1.Завести нового пользователя с возможностью администрирования.

2. Скачать конфигурационный файл для изучения.

3. Снять авторизацию с консоли. Ибо в серверную входа посторонним нет и паролирование консоли я считаю ненужным.

Это необходимо помнить

:

1

. При восстановлении пароля ( Recovering password), как это называет Cisco,(а мы будем пользоваться этим методом с некоторыми изменениями), управление должно осуществляться по терминалу через консоль, и мы должны быть подключены по терминалу через консоль к роутеру.

Приступим.

Router>show version

и узнаем версию вашего продукта и состояние регистра? Ключевым словом является Configuration register is. для

Cisco 2800 должно быть 0x2102.

Перезагружаем маршрутизатор кнопкой выключения питания.

При загрузке операционной системы нажимаем Ctrl+Break

и должны увидеть в терминале следующее:

System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Copyright (c) 1999 by cisco Systems, Inc.

TAC:Home:SW:IOS:Specials for info

PC = 0xfff0a530, Vector = 0x500, SP = 0x680127b0

C2600 platform with 32768 Kbytes of main memory

PC = 0xfff0a530, Vector = 0x500, SP = 0x80004374

monitor: command “boot” aborted due to user interrupt

rommon 1 >

Меняем состояние регистра для следующей перезагрузки , вводя команды:

rommon 1 >confreg 0x2142

You must reset or power cycle for new config to take effect

rommon 2 >reset

При запросе

Would you like to enter the initial configuration dialog? [yes/no]:

Нужно ответить no.

Видим подобное:

M860 processor: part number 0, mask 49

Bridging software.

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

2 Ethernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

1 ISDN Basic Rate interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash partition 1 (Read/Write)

8192K bytes of processor board System flash partition 2 (Read/Write)

— System Configuration Dialog —

Would you like to enter the initial configuration dialog? [yes/no]: n

Press RETURN to get started!

Жмем Enter, и вводим:

Router>enable

Router#copy startup-config running-config

Destination filename [running-config]?

1324 bytes copied in 2.35 secs (662 bytes/sec)

Router#

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Далее следующей командой вводим своего пользователя и даем ему административные права:

Router(config)#username gupop privilege 15 secret 1234567

Следующими командами снимаем авторизацию в консоли:

Router(config)#line con 0

Router(config-line)# no login

Router(config-line)#exit

Router(config)#exit

Далее проверяем сетевые интерфейсы:

Router#show ip interface brief

Пример:

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 10.200.40.37 YES TFTP administratively down down

Serial0/0 unassigned YES TFTP administratively down down

При вводе маршрутизатора в режим rommon сетевые интерфейсы автоматически отключаются.

По-этому поднимаем интерфейсы.

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int et 0/0

Router(config-if)#no shutdown

Router(config-if)#exit

И так с каждым интерфейсом.

Примечание.

Если у нас созданы подинтерфейсы

:

Например:

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

description VLAN of Servers

encapsulation dot1Q 2

ip address 192.168.253.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/0.2

description VLAN of WorkGroups

encapsulation dot1Q 1 native

ip address 192.168.254.1 255.255.255.0

ip nat inside

!

то поднимаем interface GigabitEthernet0/0 и подинтерфейсы поднимутся автоматически

.

Восстанавливаем старое значение регистра для следующей загрузки.

Router(config)#config-register 0x2102

Сохраняем конфигурацию:

Router(config)#copy run start

Копируем конфигурационный файл на tftp сервер:

Router#copy running-config tftp

Address or name of remote host []?1.1.1.2

Destination filename [router-confg]?router-confg

!!

776 bytes copied in 0.800 secs (970 bytes/sec)

Перегружаемся

Router# reload

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *