Ошибка при установке расширения Gd

При установке расширения Gd для php возникла проблема — расширение просто не ставилось, на экран ничего не писалось.

 

Решение:

Смотрим  логи установки:

[server]# tail -f /usr/local/ispmgr/var/pkgctl.log

и запускаем установку расширения из панели управления.

Переключаемся в шелл и смотрим на лог установки.

Нас интересуют строки, содержащие “return=1? :

[47856] [1;36mEXTINFO Execute (PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; cd /usr/ports/graphics/php5-gd; make clean; make BATCH=yes install clean) return=1 exited

return=1 — означает что что-то пошло не так.

 

Пробуем выполнить это действие самостоятельно:

[server]# cd /usr/ports/graphics/php5-gd; make clean; make BATCH=yes install clean

и наблюдаем следующую ошибку:

Found libtool-1.5.26, but you need to upgrade to libtool>=2.2

Т.е. требуется libtool2.2:

Ставим:

[server]# cd /usr/ports/devel/libtool22; make clean && make install clean

Запускаем заново установку расширения Gd в панели управления.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *